Installation 2.1 and 2.2 error.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Installation 2.1 and 2.2 error.

realvava
This post was updated on .
Can not install noone version

I try to install 2.2 (last) and 2.1 (stable) version on Ubuntu 14.04 amd64

It is last strings of installation VSM v2.2
--------------------------------------------------------
[Error]: One or more agent installations failed.
[Error]: Displaying the last 10 lines of failed agent output:
[Error]: Agent [AGENT-IP] failed:
...
  File "/usr/local/lib/python2.7/dist-packages/vsm/manifest/parser.py", line 607, in format_to_json
    return self._format_server_manifest_to_json(check_manifest_tag)
  File "/usr/local/lib/python2.7/dist-packages/vsm/manifest/parser.py", line 426, in _format_server_manifest_to_json
    self._dict_insert_auth_key()
  File "/usr/local/lib/python2.7/dist-packages/vsm/manifest/parser.py", line 383, in _dict_insert_auth_key
    raise
TypeError: exceptions must be old-style classes or derived from BaseException, not NoneType
--------------------------

When I tried to install v2.1, I saw somes like that string
Dpkg-scanpackages: warning: repetition of the python-six package (file vsm-dep-repo / python-six_1.7.3-2 ~ cloud0_all.deb), but with a newer version;
Dpkg-scanpackages: warning: this file is used and data from vsm-dep-repo / python-six_1.5.2-1ubuntu1_all.deb is ignored!
Dpkg-scanpackages: info: 519 entries in the output file Packages were recorded.


How I can install VSM with packages from a vsm-dsp-repo folder? Without ignoring.